Obstruction cell

Sep 27, 2011 at 2:50 PM

Hi guys, I'm trying to create buildable obstruction cells with this line:

<Cell Type="obstruction" Buildable="true" X="whatever" Y="whatever" />

but I get the following error report:

Building content threw NullReferenceException: Object reference not set to an instance of an object.

It's probably an easy fix but could you tell me where I'm going wrong?

Thanks.

Developer
Sep 27, 2011 at 3:01 PM
Edited Sep 27, 2011 at 3:02 PM

Hi,

 

Obstruction is case sensitive, so make sure you’re using a capital O in there.

 

Michael

Sep 27, 2011 at 3:08 PM

Changed it to capital O but same error report.

Developer
Sep 27, 2011 at 3:11 PM

If you remove those Obstruction cells, do you still get the same error?

Sep 27, 2011 at 3:17 PM

No, it's the original code which runs fine.

I just inserted a block under <SpecialCells>beneath the entrance and exit special cells.

Developer
Sep 28, 2011 at 5:01 AM
Edited Sep 28, 2011 at 5:01 AM

Can you send through the entire file please. Either here or directly contact me (you should be able to do it though my account or this project).

(Just the affected XML file)

Sep 30, 2011 at 10:47 AM

Did you get my file?

I sent it straight away.

Thanks.

Developer
Sep 30, 2011 at 11:02 AM

Hmm no, it seems they remove images and attachments. Sorry, I didn't know that.

Can you resend to michael AT mquandt,.com please.

Oct 11, 2011 at 10:28 PM

Did you figured this one out?

Developer
Oct 11, 2011 at 11:56 PM

You need to ensure you're using the latest code from the Source Code tab, OR give a name to every single special cell, even the Obstruction ones. This was only fixed after 1.2.